Excel VERWEIS: So verwenden Sie die Funktion

Neben Funktionen rund um Statistik und Algebra hat Excel auch die sogenannten Nachschlage- und Verweisfunktionen im Repertoire – und in dieser Gruppe ist vor allem die VERWEIS-Funktion oft sehr nützlich.

Excel mit Microsoft 365 Business von IONOS!

Organisieren Sie Ihre Daten in Excel und erstellen Sie im Handumdrehen Tabellen. In allen Office-Paketen enthalten!

Office Online
OneDrive mit 1TB
24/7 Support

Wofür braucht man den Excel-Verweis?

Nehmen wir an, Sie haben eine Tabelle mit mindestens zwei Spalten: Zu jedem Eintrag in der ersten Spalte gibt es in der gleichen Zeile einen korrespondierenden Wert in der zweiten Spalte. Wollen Sie nun der Wert zu einem bestimmten Eintrag herausfinden, können Sie entweder manuell durch die Zeilen scrollen oder Sie lassen die VERWEIS-Funktion danach suchen. Sie tragen den Suchbegriff in die Formel ein und Excel liefert den dazugehörigen Wert. Alternativ können Sie sich aber auch ein Formular mit einem Suchfeld bauen. Die Zelle mit dem Suchbegriff integrieren Sie dann ganz einfach in die Formel von VERWEIS.

Diese direkte Verwendung der Funktion ist bereits sehr hilfreich. Noch praktischer wird VERWEIS allerdings in Kombination mit anderen Funktionen.

Hinweis

Excel kennt auch die WVERWEIS-Funktion und die SVERWEIS-Funktion. Während die erste Funktion waagerecht bei der Suche vorgeht, funktioniert die zweite Funktion senkrecht. Bei der VERWEIS-Funktion können Sie hingegen frei wählen, ob Sie Zeilen oder Spalten durchsuchen wollen.

Excel: VERWEIS-Syntax

VERWEIS lässt sich in Excel in zwei Fassungen verwenden: als Vektor- und als Matrixfunktion. Die Variante als Vektorfunktion dürfte aber die wohl die populärere Version sein. Die hier gezeigte Syntax funktioniert in Excel-Versionen ab Office 2016 und Microsoft 365.

=VERWEIS(Suchkriterium;Suchvektor;[Ergebnisvektor])
  • Suchkriterium: Hier tragen Sie den Inhalt ein, nach dem Sie suchen lassen wollen, zum Beispiel Zahlenwerte, Text (in Anführungszeichen), Wahrheitswerte, Zellbezüge oder eine andere Formel.
  • Suchvektor: Dieser Bereich legt fest, in welchen Zellen die Funktion nach dem angegebenen Kriterium suchen soll. In den meisten Fällen geben Sie hier einen Zellbereich ein. Sie können die Werte allerdings auch in Form eines Arrays (in geschweiften Klammern) direkt in den Parameter eintragen.
  • Ergebnisvektor: Im optionalen Ergebnisvektor geben Sie den Bereich an, in dem der korrespondierende Wert zu finden ist. Deshalb ist es wichtig, dass dieser Parameter die gleiche Größe wie der Suchvektor hat.

In der Vektorversion können Sie immer nur eine Zeile oder eine Spalte für Such- bzw. Ergebnisbereich angeben. Dafür müssen die beiden Vektoren allerdings nicht direkt aneinander liegen. So lange beide Argumente die gleiche Größe haben, können die beiden Bereiche an komplett unterschiedlichen Orten in der Arbeitsmappe liegen.

Die Suche der Funktion ist immer ungefähr. Das heißt: Das Suchkriterium muss nicht exakt mit einem der Werte im Suchvektor übereinstimmen. Excel versucht dann, den nächstkleineren Wert zu finden. Das kann aber nur funktionieren, wenn Sie die Liste zuvor aufsteigend sortiert haben. Ist die Tabelle durcheinander, gibt die Funktion falsche Ergebnisse aus.

Tipp

Ist der gesuchte Wert kleiner als der kleinste Wert im Suchvektor, gibt VERWEIS einen Fehler aus, da immer nur der nächstkleinere Eintrag ausgewählt werden kann, wenn die Suche kein genaues Ergebnis findet.

VERWEIS in Excel: Beispiele

Wie bereits erwähnt, ist VERWEIS am einfachsten in Form eines Suchformulars realisierbar. Damit durchsuchen Sie beispielsweise eine komplette Spalte und lassen sich dann den korrespondierenden Wert anzeigen. In untenstehendem Beispiel verwenden wir eine Inventarliste. Jedes Artikelgruppe hat eine eigene Bezeichnung, zu der wir die Anzahl im Lager ermitteln möchten.

=VERWEIS($A$12;A2:A10;B2:B10)
Mit der Excel-VERWEIS-Funktion erstellen Sie ein einfaches Suchformular.

In das Suchfeld tragen Sie die entsprechende Inventarnummer ein. Die VERWEIS-Funktion gibt dann die Anzahl der Objekte wieder. Dynamisch kann nun nach jeder Artikelnummer gesucht werden.

Die VERWEIS-Funktion lässt sich allerdings auch sehr gut mit anderen Funktionen in Excel kombinieren. So lassen sich beispielsweise die Ergebnisse von einem Verweis oder auch mehreren Verweisen miteinander summieren.

=SUMME(VERWEIS($A$12;A2:A10;B2:B10);VERWEIS($B$12;A2:A10;B2:B10))
Übergeben Sie das Ergebnis von VERWEIS direkt an die Funktion SUMME.

Die Formel addiert nun die Anzahl zweier unterschiedlicher Artikel.

Aber auch die Eingabe des Suchkriteriums können Sie per Formel realisieren. In unserem Beispiel bestehen die Artikelbezeichnungen immer aus einer Kombination aus einem Buchstaben und einer Zahl. Diese beiden Elemente können Sie auch getrennt eingeben und dann mit der Funktion VERKETTEN zusammenziehen. Da der erste Bestandteil der Bezeichnungen nur aus einem von drei möglichen Buchstaben besteht, lohnt es sich sogar, hierfür ein Excel-Dropdown-Menü anzulegen.

=VERWEIS(VERKETTEN($A$12;$B$12);A2:A10;B2:B10)
Lassen Sie das Suchkriterium durch die VERKETTEN-Funktion zusammensetzen.

Nun können Sie zwei separate Suchfelder nutzen, um die Anzahl einer Artikelgruppe zu ermitteln.

Die VERWEIS-Funktion hat noch einen anderen Vorteil, der sich ergibt, wenn man die ungenaue Suche nutzt und dabei den Ergebnisvektor leer lässt. So kann man nämlich ermitteln, welcher Wert innerhalb einer Liste dem gesuchten Wert nahekommt. Wenn man diesen Vorgang mit der Excel-Funktion VERGLEICH verbindet, gibt Excel sogar die entsprechende Zeile aus, in der der Wert zu finden ist.

=VERGLEICH(VERWEIS(55;A1:A10);A1:A10)
VERWEIS sucht nach dem Wert, der am nächsten am Suchkriterium dran ist, und VERGLEICH gibt die Stelle innerhalb der Liste aus.
HiDrive Cloud Speicher von IONOS!

Ihr sicherer Online-Speicher mit Serverstandort in Deutschland: zentral speichern, teilen und bearbeiten!

Überall verfügbar
Gemeinsamer Zugriff
Hochsicher (DSGVO-konform)
Page top