Excel: Die INDIREKT-Funktion erklärt

Beim regelmäßigen Umgang mit Excel schreibt man immer mal wieder Zellbezüge in seine Formeln. Erst das macht Excel so richtig wertvoll: Statt wie bei der gewöhnlichen Rechenarbeit, die viele nur noch aus der Schule kennen, die Werte direkt in die Formel einzutragen, geben wir bei Excel einfach bestimmte Zellen an, aus denen die Werte gezogen werden sollen – und das über ganze Spalten und Zeilen hinweg. So wird das Tabellenkalkulationsprogramm von Microsoft dynamisch.

Mit der Excel-Funktion INDIREKT können Sie noch einen Schritt weitergehen: Statt den Zellbezug in die Funktion zu schreiben, ziehen Sie ihn einfach aus einer anderen Zelle oder stellen ihn sich aus mehreren Angaben zusammen. Klingt komplex, kann aber sehr nützlich sein!

Wofür verwendet man die Excel-Formel INDIREKT?

Excel bietet Ihnen mit INDIREKT die Möglichkeit, den Bezug aus einer anderen Zelle zu ziehen, statt ihn direkt in eine Funktion einzutragen. Damit können Nutzer dann aber auch Zellbezüge zusammensetzen, also den ersten Bestandteil aus einer Zelle und den zweiten aus einer anderen beziehen. In der Zelle, die man mit INDIREKT füllt, erscheint dann der Wert, auf den der zusammengestellte Bezug verweist.

Für sich allein stehend, wird INDIREKT selten eingesetzt. Denkbar ist solch ein Einsatz, wenn man eine Art dynamisches Formular baut, bei dem der Zellbezug per Eingabe in eine Zelle stetig geändert werden soll. In den meisten Fällen kommt INDIREKT aber in Kombination mit anderen Funktionen zum Einsatz.

Darüber hinaus ist es möglich, mit INDIREKT einen Wert aus einem anderen Tabellenblatt darzustellen. Theoretisch ist es sogar denkbar, auf eine andere Arbeitsmappe zu verweisen. Solch ein Bezug funktioniert allerdings nur dann, wenn die andere Arbeitsmappe auch geöffnet ist. Ist die Datei, auf die sich INDIREKT bezieht, hingegen geschlossen, erscheint eine Fehlermeldung anstelle des Wertes.

Syntax der INDIREKT-Funktion

INDIREKT besteht aus einem zwingenden und einem optionalen Argument.

=INDIREKT(Bezug;[A1])
  • Bezug: Hier trägt man den Zellbezug oder die Zellbezüge ein. Man kann einen Teil der Zellreferenz auch direkt (und zwar in Anführungszeichen) in die Funktion schreiben. Die Verknüpfung von zwei Bezugsteilen funktioniert über das kaufmännische Und-Zeichen (&).
  • A1: Das optionale Argument gibt an, in welchem Format Sie den Zellbezug erstellen wollen. Lässt man das Argument frei oder schreibt WAHR in die Funktion, verwendet man das A1-Format. Bei FALSCH reagiert die Funktion auf das Z1S1-Format.

Excel wird in den meisten Fällen im A1-Format verwendet. Dabei werden die Zeilen durchnummeriert (A1, A2, A3 …) und die Spalten mit fortlaufenden Buchstaben (A1, B1, C1 …) dargestellt. Man kann in den Einstellungen des Programms aber auch angeben, dass man das Z1S1-Format verwenden will, bei dem sowohl Zeilen als auch Spalten durchnummeriert werden. Z5S10 wäre demnach die Zelle am Schnittpunkt der fünften Zeile und der zehnten Spalte.

Fakt

Die Z1S1-Schreibweise entstammt noch Multiplan – dem Vorgänger Excels. Man kann die Schreibweise aber auch heute noch in den Optionen des Programms unter Formeln aktivieren.

Beispiele für INDIREKT in Excel

Steht in der Zelle A1 beispielsweise B1 und in B1 befindet sich der Wert 5, ergibt folgende Formel wiederum den Wert 5.

=INDIREKT(A1)

Excel erkennt hierbei die Texteingabe in der Zelle A1 als Signal für den Zellbezug und wertet diesen daraufhin aus.

Komplexer wird die Funktion, wenn man den Zellbezug aufteilt.

=INDIREKT("B" & A1)

In diesem Beispiel steht nur noch eine Zahl in der Zelle A1. Den Spaltenbestandteil des Bezugs geben Sie direkt als Buchstaben in die Formel ein.

Sie können aber auch sowohl die Zeile als auch die Spalte in zwei verschiedenen Zellen unterbringen.

=INDIREKT(A2 & A1)

Interessant ist die Verwendung von INDIREKT auch dann, wenn man die Formel benutzt, um auf Werte in anderen Tabellenblättern zu verweisen. Zum Einsatz kommt das beispielsweise, wenn man über mehrere Blätter ähnliche Tabellen und Berechnungen vornimmt und auf einem Übersichtsblatt ausgewählte Werte der anderen Blätter anzeigen möchte. Den Namen des Tabellenblattes zieht man wiederum aus einer Zelle.

=INDIREKT("'"&A1&"'!C1")

In der Zelle A1 befindet sich der Name des Tabellenblattes und in diesem Blatt liegt der gewünschte Wert in der Zelle C1. Die zusätzlichen Zeichen im Argument der Funktion ergeben sich dadurch, dass man den kompletten Text eines solchen Bezugs (inklusive Anführungs- und Ausrufezeichen) wiedergeben muss. Für das benötigte Anführungszeichen müssen Sie – da es sich um eine Texteingabe in der Funktion handelt – ein einfaches Anführungszeichen in doppelte Anführungszeichen setzen. Dann folgt der Text aus Zelle A1 und anschließend eine längere Texteingabe: Der Tabellenblattname wird wieder mit einem Anführungszeichen abgeschlossen, dann kommt ein obligatorisches Ausrufezeichen und schließlich die Zelle, deren Wert man auslesen möchte.

Nun können Sie entweder den Wert in Zelle A1 – zum Beispiel mit einem Dropdown-Menü – immer wieder anpassen oder Sie ordnen die Werte der verschiedenen Blätter untereinander an. Dabei profitieren Sie davon, dass beim Runterziehen der Formel (per Mauszeiger) Excel die Referenzen automatisch an die neue Position der Funktion anpasst.

Excel: INDIREKT und andere Funktionen

Man verwendet die Excel-Formel INDIREKT oft in Kombination mit anderen Funktionen. INDIREKT ist zum Beispiel dann sinnvoll, wenn man mit der SUMME-Funktion Werte aus einem anderen Tabellenblatt addieren möchte. Statt also wie im vorangegangen Beispiel die Summe bereits in dem entsprechenden Blatt zu erzeugen und diese dann in einer Übersicht wiederzugeben, summiert man die Werte erst in der Übersicht.

 

=SUMME(INDIREKT("'"&A3&"'!B1:B5"))

Mit dieser Formel summieren Sie die Zellen B1 bis B5 in einem Tabellenblatt, das Sie in der Zelle A3 näher bestimmt haben.

Gleichzeitig ist es Ihnen möglich, mit der Summenfunktion Werte aus unterschiedlichen Tabellenblättern zu addieren.

=SUMME(INDIREKT("'"&A1&"'!C1");INDIREKT("'"&A2&"'!C1");INDIREKT("'"&A3&"'!C1"))

Mit dieser Technik lassen sich auch viele weitere mathematische oder statistische Funktionen (beispielsweise MITTELWERT) in Excel erweitern.


Auf dem Laufenden bleiben?

Jetzt für unseren Newsletter anmelden und gratis Online-Marketing Whitepaper für lokale Anbieter sichern!