# Beheben von SSH-Fehlern

Erfahren Sie, wie Sie einige der häufigsten Fehler beheben können, die bei der Verbindung zu einem Server mit [SSH](https://www.ionos.at/digitalguide/server/tools/secure-shell-ssh/ "Secure Shell (SSH)") auftreten können.

## WARNING: REMOTE HOST IDENTIFICATION HAS CHANGED

Dieser Fehler wird ausgelöst, wenn sich das [SSL-Zertifikat](https://www.ionos.at/digitalguide/websites/webseiten-erstellen/ssl-zertifikat/ "SSL-Zertifikat") für einen Server ändert. Der Fehler ist darauf ausgelegt, einen potenziellen [“Man in the middle“](https://www.ionos.at/digitalguide/server/sicherheit/man-in-the-middle-attack-angriffsmuster-im-ueberblick/ "Man-in-the-middle-Attack: Angriffsmuster im Überblick") Angriff zu markieren. Die meisten Leute stoßen jedoch erst nach dem Neuaufbau eines Servers auf den Fehler.

Wenn Ihr Server neu ist oder sein Image seit der letzten Verbindung neu installiert wurde, klicken Sie einfach auf “Akzeptieren”, um das neue SSL-Zertifikat zu akzeptieren und fortzufahren.

## Zugriff verweigert oder Authentifizierung abgelehnt

Die häufigste Ursache für den Fehler “Access Denied” oder “Authentication Refused” ist, dass der SSH-Benutzername oder das Passwort falsch geschrieben wurde oder falsch ist.

- Vergewissern Sie sich, dass Sie den Benutzernamen korrekt eingegeben haben.
- Achten Sie darauf, dass Sie den richtigen Benutzernamen verwenden.
- Überprüfen Sie das Passwort erneut. Um sicher zu gehen, dass Sie es richtig eingeben, kopieren Sie es und fügen Sie es in das Feld ein. Hinweis: Sie können mit Shift+Enter Text in die Eingabeaufforderung einfügen.

**Das anfängliche Root-Passwort für ein Linux Cloud Server finden.**

Wenn Sie einen Linux Cloud Server haben, wird das anfängliche Standard-Root-Passwort im Control-Center aufgelistet.

Melden Sie sich bei Ihrem IONOS-Konto an, klicken Sie auf Systemsteuerung, um das Dropdown-Menü zu öffnen, und klicken Sie dann auf Cloud Panel

[![Bild: Dropdown-Menü - Cloud Panel](https://www.ionos.at/digitalguide/fileadmin/_processed_/1/2/csm_root-1_37be2dccb3.webp "Dropdown-Menü - Cloud Panel")](https://www.ionos.at/digitalguide/fileadmin/DigitalGuide/Screenshots_2020/root-1.jpg) Dropdown-Menü - Cloud Panel Klicken Sie auf der Seite Server auf den Servernamen, um Ihren Server auszuwählen.

[![Bild: Server auszuwählen](https://www.ionos.at/digitalguide/fileadmin/_processed_/d/f/csm_root-2_72ba188eb8.webp "Server auszuwählen")](https://www.ionos.at/digitalguide/fileadmin/DigitalGuide/Screenshots_2020/root-2.jpg) Server auszuwählen Scrollen Sie nach unten zur Zeile **Initiales Passwort** und klicken Sie auf **Passwort anzeigen**, um das Standard-Rootpasswort anzuzeigen.

[![Bild: Passwort anzeigen](https://www.ionos.at/digitalguide/fileadmin/_processed_/2/c/csm_root-3_9d0af9cc32.webp "Passwort anzeigen")](https://www.ionos.at/digitalguide/fileadmin/DigitalGuide/Screenshots_2020/root-3.jpg) Passwort anzeigen Sie können das Passwort aus der Popup-Meldung kopieren und einfügen.

[![Bild: Passwort kopieren und einfügen](https://www.ionos.at/digitalguide/fileadmin/_processed_/c/3/csm_root-4_6cb5397a53.webp "Passwort kopieren und einfügen")](https://www.ionos.at/digitalguide/fileadmin/DigitalGuide/Screenshots_2020/root-4.jpg) Passwort kopieren und einfügen  Hinweis Wenn Sie das Passwort für root geändert haben, wird das neue Passwort hier nicht angezeigt.

## Port 22: Verbindung abgelehnt

Es gibt mehrere mögliche Gründe, warum Sie den Fehler “Port 22: Connection refused” erhalten, wenn Sie versuchen, sich über SSH mit Ihrem Server zu verbinden.

### Ist der Server erreichbar?

Das erste, was Sie tun sollten, ist herauszufinden, ob der Server Verbindungen zum Port 22 von einem anderen Ort im Internet erlaubt. Verwenden Sie das Tool unter [http://www.infobyip.com/sshservertest.php](https://www.infobyip.com/sshservertest.php "infobyip.com"), um Ihren Server zu überprüfen.

Wenn diese Seite in der Lage ist, sich mit Ihrem Server zu verbinden, dann liegt das Problem auf Ihrer Seite. Sie befinden sich möglicherweise hinter einer Firewall, die den Datenverkehr auf Port 22 blockiert. Viele Firmen und Bildungseinrichtungen blockieren diesen Port aus Sicherheitsgründen.

Wenn die Website keine Verbindung zu Ihrem Server herstellen kann, befindet sich das Problem entweder auf dem Server oder zwischen dem Server und dem Internet.

### Is SSH installiert?

Wenn es sich um eine Neuinstallation handelt, wird der SSH-Server (sshd) möglicherweise nicht installiert. Sie können mit folgendem Befehl überprüfen, ob er auf Ihrem System installiert ist:

```none
which sshd
```

Wenn das System mit einem Pfad wie /usr/sbin/sshd antwortet, dann wurde der SSH-Server installiert. Wenn es stattdessen mit einem Fehler wie /usr/bin/which antwortet: no sshd in (/usr/local/bin:/usr/bin:/usr/local/sbin:/usr/local/sbin:/usr/sbin), dann müssen Sie sowohl den SSH-Client als auch den SSH-Server installieren.

Auf Ubuntu und Debian installieren Sie diese Programme mit dem Befehl:

```none
sudo apt-get install openssh-server openssh-clients
```

Auf CentOS installieren Sie diese Programme mit dem Befehl:

```none
sudo yum -y install openssh-server openssh-clients
```

### SSH starten oder neu starten

Überprüfen Sie mit folgendem Befehl, ob der SSH-Dienst ausgeführt wird:

```none
sudo ps -aux | grep sshd
```

Zusätzlich zum Ergebnis des [grep-Befehls](https://www.ionos.at/digitalguide/server/konfiguration/linux-grep-befehl/ "Linux: grep-Befehl") sollten Sie den SSHD-Prozess laufen sehen.

[![Bild: SSHD-Prozess](https://www.ionos.at/digitalguide/fileadmin/_processed_/6/9/csm_ssh-port-22-sshd-running_b79823de2c.webp "SSHD-Prozess")](https://www.ionos.at/digitalguide/fileadmin/DigitalGuide/Screenshots_2020/ssh-port-22-sshd-running.jpg) SSHD-Prozess Wenn der SSHD-Prozess nicht aktiv ist, starten Sie ihn.

- Auf Ubuntu und Debian: sudo service ssh start
- Unter CentOS: sudo systemctl start sshd

Wenn der SSHD-Prozess läuft, muss er möglicherweise neu gestartet werden.

- Auf Ubuntu und Debian: sudo service ssh restart
- Auf CentOS: sudo systemctl restart sshd

### Lauscht SSH auf Port 22?

Port 22 ist der Standard-Port für SSH-Verbindungen. Wenn der SSH-Daemon Ihres Servers konfiguriert wurde, um auf einen anderen Port als Port 22 zu hören, verweigert er SSH-Verbindungen zu Port 22.

Um zu überprüfen, auf welchem Port SSH lauscht, verwenden Sie den Befehl:

```none
sudo netstat -apn | grep sshd
```

Die Ausgabe dieses Befehls zeigt Ihnen an, auf welchem Port SSH lauscht.

[![Bild: auf welchem Port lauscht SSH](https://www.ionos.at/digitalguide/fileadmin/_processed_/f/2/csm_ssh-port-22-netstat-which-port-ssh-is-listening-to_85c1807c14.webp "auf welchem Port lauscht SSH")](https://www.ionos.at/digitalguide/fileadmin/DigitalGuide/Screenshots_2020/ssh-port-22-netstat-which-port-ssh-is-listening-to.jpg) auf welchem Port lauscht SSH Wenn SSH auf einen anderen Port als Port 22 hört, müssen Sie Ihre Verbindungseinstellungen entsprechend anpassen.

In PuTTY für Windows können Sie den Port im Haupteinstellungsbildschirm einstellen.

[![Bild: PuTTY für Windows](https://www.ionos.at/digitalguide/fileadmin/_processed_/1/4/csm_ssh-port-22-change-putty-configurations_38e04caee6.webp "PuTTY für Windows")](https://www.ionos.at/digitalguide/fileadmin/DigitalGuide/Screenshots_2020/ssh-port-22-change-putty-configurations.jpg) PuTTY für Windows ### Überprüfen Sie die SSH-Konfigurationsdatei auf Tippfehler.

Wenn Sie Ihre SSH-Konfigurationen kürzlich bearbeitet haben, überprüfen Sie die Syntax der Datei mit:

```none
sudo sshd –T
```

### Überprüfen Sie Ihre Firewall-Regeln:

Es gibt mehrere mögliche Firewall-Szenarien, die zu diesem SSH-Fehler führen können, einschließlich:

- Wenn Sie kürzlich eine Firewall auf Ihrem Server installiert oder aktualisiert haben, haben Sie möglicherweise aus Versehen den SSH-Zugriff auf Port 22 blockiert (oder nicht erlaubt).
- Wenn Ihr Server kürzlich neu gestartet wurde, wurden Ihre Firewall-Regeln möglicherweise beim Booten nicht geladen, um den Datenverkehr auf Port 22 zu ermöglichen.

### UFW-Regeln prüfen

Wenn Sie ufw als Firewall auf Ihrem Server verwenden, können Sie alle Ihre ufw-Regeln mit folgendem Befehl auflisten:

```none
sudo ufw verbose
```

Sie können den Zugriff über SSH mit folgendem Befehl zulassen:

```none
sudo ufw allow ssh
```

### Iptables-Regeln prüfen

Um zu sehen, ob Sie eine iptables-Regel verwenden, die den SSH-Verkehr blockiert, geben Sie den Befehl ein:

```none
sudo iptables -L | grep ssh
```

Sie können auch alle Ihre iptables-Regeln mit folgendem Befehl auflisten:

```none
sudo iptables -L
```

Um eine iptables-Regel zu löschen, bearbeiten Sie die Datei /etc/sysconfig/iptables und laden Sie dann die iptables-Konfiguration mit diesem Befehl neu:

```none
sudo iptables -F
```

### Überprüfen Sie Ihre Cloud Panel Firewall-Richtlinie.

Melden Sie sich bei Mein IONOS an und gehen Sie zu Ihrem Cloud Panel. Gehen Sie zu **Infrastruktur -&gt; Server** und klicken Sie auf den Servernamen, um Ihren Server auszuwählen.

[![Bild: Cloud Panel Infrastruktur](https://www.ionos.at/digitalguide/fileadmin/_processed_/7/0/csm_ssh-port-22-click-to-select-server_9fdd94f4f4.webp "Cloud Panel Infrastruktur")](https://www.ionos.at/digitalguide/fileadmin/DigitalGuide/Screenshots_2020/ssh-port-22-click-to-select-server.jpg) Cloud Panel Infrastruktur Scrollen Sie nach unten, um zu sehen, ob eine Firewall-Richtlinie aufgeführt ist.

[![Bild: Firewall-Richtlinie](https://www.ionos.at/digitalguide/fileadmin/_processed_/f/5/csm_ssh-port-22-show-firewall-policy_a6a70deebf.webp "Firewall-Richtlinie")](https://www.ionos.at/digitalguide/fileadmin/DigitalGuide/Screenshots_2020/ssh-port-22-show-firewall-policy.jpg) Firewall-Richtlinie Wenn eine Firewall-Richtlinie aufgeführt ist, bearbeiten Sie diese Richtlinie, um SSH-Verbindungen zuzulassen.

Klicken Sie dazu auf **Netzwerk -&gt; Firewall-Richtlinien**.

[![Bild: Firewall-Richtlinien](https://www.ionos.at/digitalguide/fileadmin/_processed_/9/b/csm_ssh-port-22-network-firewall-policies_1b4c233b45.webp "Firewall-Richtlinien")](https://www.ionos.at/digitalguide/fileadmin/DigitalGuide/Screenshots_2020/ssh-port-22-network-firewall-policies.jpg) Firewall-Richtlinien Klicken Sie hier, um die Firewall-Richtlinie auszuwählen, die Ihrem Server zugeordnet ist.

[![Bild: Firewall-Richtlinie auswählen](https://www.ionos.at/digitalguide/fileadmin/_processed_/5/2/csm_ssh-port-22-select-firewall-policy_4d0175e0a8.webp "Firewall-Richtlinie auswählen")](https://www.ionos.at/digitalguide/fileadmin/DigitalGuide/Screenshots_2020/ssh-port-22-select-firewall-policy.jpg) Firewall-Richtlinie auswählen Wenn Ihre Firewall-Richtlinie keine Regel für die Zulassung von SSH enthält, scrollen Sie nach unten und klicken Sie auf **Vordefinierte Werte hinzufügen.**

[![Bild: Vordefinierte Werte hinzufügen](https://www.ionos.at/digitalguide/fileadmin/_processed_/8/d/csm_ssh-port-22-add-predefined-value_cb7fcd7057.webp "Vordefinierte Werte hinzufügen")](https://www.ionos.at/digitalguide/fileadmin/DigitalGuide/Screenshots_2020/ssh-port-22-add-predefined-value.jpg) Vordefinierte Werte hinzufügen Klicken Sie auf **SSH.**

[![Bild: SSH Auswahl](https://www.ionos.at/digitalguide/fileadmin/_processed_/9/c/csm_ssh-port-22-add-ssh_90db83bce2.webp "SSH Auswahl")](https://www.ionos.at/digitalguide/fileadmin/DigitalGuide/Screenshots_2020/ssh-port-22-add-ssh.jpg) SSH Auswahl Klicken Sie auf das grüne Häkchen, um diese neue Regel zu Ihrer Firewall-Richtlinie hinzuzufügen.

[![Bild: Firewall-Richtlinie hinzufügen](https://www.ionos.at/digitalguide/fileadmin/_processed_/5/d/csm_ssh-port-22-green-check-mark_c4e9e8df95.webp "Firewall-Richtlinie hinzufügen")](https://www.ionos.at/digitalguide/fileadmin/DigitalGuide/Screenshots_2020/ssh-port-22-green-check-mark.jpg) Firewall-Richtlinie hinzufügen ## Netzwerkfehler: Softwarebedingter Verbindungsabbruch

Der Fehler “Netzwerkfehler: Softwarebedingter Verbindungsabbruch” tritt auf, wenn Ihr Desktop-Computer die Verbindung unerwartet beendet. Dies kann passieren, wenn Sie ein Internetproblem haben, einschließlich eines kurzen Verbindungsproblems.

Es kann auch passieren, wenn der Server nicht mehr lauscht. Ihr Desktop sendet mehrere Pakete an den Server, bevor er die Verbindung aufgibt und die Sitzung beendet.

## Schreibvorgang fehlgeschlagen: Verbindung nicht möglich Netzwerkfehler: Connection reset by peer

Wenn eine SSH-Sitzung mit “Write failed: broken pipe” oder “Network error: Connection reset by peer”, beendet wird, bedeutet dies, dass die Sitzung abgelaufen ist.

Das Timeout kann auf Ihrem Computer, auf dem Server oder auf einer Firewall dazwischen auftreten. Die SSH-Sitzung wird automatisch geschlossen, wenn sie zu lange im Leerlauf bleibt.

Die Lösung besteht darin, Ihren SSH-Client so einzustellen, dass er “Keepalive-Pakete” sendet. Dies sind kleine Datenpakete, die in regelmäßigen Abständen automatisch versendet werden. Dadurch wird dem Netzwerk mitgeteilt, dass Ihre Verbindung noch aktiv ist.

## Einstellung Keepalive

**PuTTY unter Windows**

Wenn Sie PuTTY unter Windows verwenden, um sich mit Ihrem Server zu verbinden, können Sie den Timeout unter Verbindung einstellen. Stellen Sie die “Sekunden zwischen den Keepalives ein, 0 (zum Ausschalten) bis 60”.

[![Bild: Timeout einstellen](https://www.ionos.at/digitalguide/fileadmin/_processed_/7/6/csm_putty-config-timeout_5793c775dd.webp "Timeout einstellen")](https://www.ionos.at/digitalguide/fileadmin/DigitalGuide/Screenshots_2020/putty-config-timeout.jpg) Timeout einstellen **Linux oder Unix**

Wenn Sie einen Linux- oder Unix-Desktop verwenden, um sich mit Ihrem Server zu verbinden, bearbeiten Sie /etc/ssh/ssh/sshd\_config und fügen Siefolgendes hinzu:

```none
ServerAliveInterval 60
```

Speichern und schließen Sie die Datei, und starten Sie dann SSH neu, damit die Änderungen wirksam werden.

## Netzwerkfehler: Zeitüberschreitung der Verbindung

Der “Netzwerkfehler: Der Fehler Connection timed out” bedeutet, dass Ihr SSH-Client keine Antwort vom Server erhalten hat. Es gibt mehrere mögliche Gründe für diesen Fehler:

**Ein Internetausfall an Ihrem Standort**

Warten Sie einen Moment und versuchen Sie es dann erneut. Wenn Sie immer noch die Fehlermeldung erhalten, überprüfen Sie Ihre Internetverbindung, indem Sie eine Website wie Google in Ihrem Browser besuchen.

**Ein ernsthaftes Netzwerkproblem irgendwo zwischen Ihrem Standort und dem Server.**

Sie können den Zustand der Verbindung zwischen Ihrem Standort und dem Server überprüfen, indem Sie eine Traceroute ausführen. Dies sendet ein paar Datenpakete an Ihren Server und gibt Auskunft darüber, wie viele Hops die Daten machen mussten und wie lange es für jeden Hop gedauert hat.

- **Windows 10**

Um eine Traceroute unter Windows 10 auszuführen, klicken Sie mit der rechten Maustaste auf die Schaltfläche **Start.**

[![Bild: Windows Start](https://www.ionos.at/digitalguide/fileadmin/_processed_/4/a/csm_tracert-1_cd288e5683.webp "Windows Start")](https://www.ionos.at/digitalguide/fileadmin/DigitalGuide/Screenshots_2020/tracert-1.jpg) Windows Start Klicken Sie auf **Suchen.**

[![Bild: Suchen](https://www.ionos.at/digitalguide/fileadmin/_processed_/d/f/csm_tracert-2_90927635e2.webp "Suchen")](https://www.ionos.at/digitalguide/fileadmin/DigitalGuide/Screenshots_2020/tracert-2.jpg) Suchen Geben Sie “cmd” in das Suchfeld ein.

[![Bild: Geben Sie “cmd” in das Suchfeld ein](https://www.ionos.at/digitalguide/fileadmin/_processed_/f/0/csm_tracert-3_0ba2749f4e.webp "Geben Sie “cmd” in das Suchfeld ein")](https://www.ionos.at/digitalguide/fileadmin/DigitalGuide/Screenshots_2020/tracert-3.jpg) Geben Sie 'cmd' in das Suchfeld ein Klicken Sie auf die **Eingabeaufforderung**, wenn sie angezeigt wird.

[![Bild: Eingabeaufforderung](https://www.ionos.at/digitalguide/fileadmin/_processed_/0/e/csm_tracert-4_5df53984ee.webp "Eingabeaufforderung")](https://www.ionos.at/digitalguide/fileadmin/DigitalGuide/Screenshots_2020/tracert-4.jpg) Eingabeaufforderung Führen Sie eine Traceroute zu Ihrem Server mit dem Befehl aus:

```none
tracert [IP address or domain name]
```

Wenn Ihr Server beispielsweise http://example.com, autet der Befehl:

```none
tracert example.com
```

Die Ausgabe wird in etwa so aussehen:

[![Bild: Traceroute Ausgabe](https://www.ionos.at/digitalguide/fileadmin/_processed_/e/d/csm_tracert-5_73b901d8b5.webp "Traceroute Ausgabe")](https://www.ionos.at/digitalguide/fileadmin/DigitalGuide/Screenshots_2020/tracert-5.jpg) Traceroute Ausgabe Wenn Sie extrem hohe Ping-Zeiten (etwas mehr als 300ms wird als “hoch” angesehen) oder übermäßige Pakete (die mit einem Sternchen gekennzeichnet sind) sehen, könnte dies die Ursache für Ihr Problem sein.

Hinweis: Der letzte “hop” zum Endserver zeigt oft verlorene Pakete und “Request timed out”, auch wenn der Server ohne Probleme in Betrieb ist. Aus Sicherheitsgründen reagieren die meisten Server nicht auf Ping-Befehle.

**Firewall-Regeln verhindern die Verbindung**

Wenn Sie sich zu Hause oder am Arbeitsplatz hinter einer Firewall befinden, kann dies das Problem verursachen. Sie sollten auch sicherstellen, dass die Firewall Ihres Servers so konfiguriert ist, dass sie SSH-Verbindungen zulässt.

**Der Server kann offline sein oder heruntergefahren werden.**

Warten Sie einen Moment und versuchen Sie, sich wieder zu verbinden. Wenn Ihr Server neu gestartet wurde, sollte er in Kürze wieder online sein.

Wenn der Server immer noch nicht antwortet, können Sie den Status des Servers in Ihrem IONOS Control-Center überprüfen.

Melden Sie sich bei Ihrem IONOS Konto an, klicken Sie auf Controll-Center, um das Dropdown-Menü zu öffnen, und klicken Sie dann auf Cloud Panel.

Klicken Sie auf der Seite **Serve**r auf den Servernamen, um Ihren Server auszuwählen. Die **Status**leuchte leuchtet grün für einen Server, der in Betrieb ist. Sie wechselt bei Problemen auf gelb oder rot.

Um den Server zu überprüfen, klicken Sie auf die Schaltfläche Aktionen und wählen Sie dann **Access KVM Console** aus dem Dropdown-Menü.

[![Bild: Access KVM Console](https://www.ionos.at/digitalguide/fileadmin/_processed_/5/6/csm_kvm-1_e0d251d60b.webp "Access KVM Console")](https://www.ionos.at/digitalguide/fileadmin/DigitalGuide/Screenshots_2020/kvm-1.jpg) Access KVM Console Dadurch wird die KVM-Konsole geöffnet, mit der Sie auf Ihren Server zugreifen können, als ob Sie an einer physischen am Computer angeschlossenen Tastatur sitzen würden.

Wenn Sie den Server neu starten möchten, können Sie dies von der KVM-Konsole aus mit dem Befehl tun:

```none
sudo shutdown -r now
```

Sie können Ihren Server auch über das Menü **Aktionen** neu starten, indem Sie auf **Neustart** klicken.

[![Bild: Neustart](https://www.ionos.at/digitalguide/fileadmin/_processed_/7/1/csm_kvm-2_32f14e902e.webp "Neustart")](https://www.ionos.at/digitalguide/fileadmin/DigitalGuide/Screenshots_2020/kvm-2.jpg) Neustart


This is a markdown version of: [https://www.ionos.at/digitalguide/server/knowhow/beheben-von-ssh-fehlern/](https://www.ionos.at/digitalguide/server/knowhow/beheben-von-ssh-fehlern/) for AI/LLM consumption.